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MDS / MDispersion 64 Bit Series V3.1.5 Release Notes
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Applicable Version
3.1.4.1
HASH
md5 : 87205befdf1ed7e2a00898b75d34733e
sha1 : 805c0ad8219f74e281858a8d64750f8ed4728e34

sha256 :
1bbb600f1d34f4b7abec1f05f508782f51fd19650ba23902d537eab70ef9605a
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Attention

After the update, the system will auto-reboot, automatically resuming paused
services.

Update Details

¢ Mail Serversx

Basic Setup—

(01) Fix “Send And Receive Setting” > “Maximum Mail Size” : Unable to
set values greater than 1000.

(02) Add “Al Module” (authorization required).

Advanced Setup—

Adjust “Large File Replace Setting” : After recalling the email, the file
link will be removed, and downloads will be prohibited.

s¢Mail Filter,Audit & Firewall
Audit & Filter Rule Setting—
(01) Add [Add/Edit] > “Abnormal Mail” : “Add Text on Subject” .

(02) Fix “Process Method: Send to Auditors” : Auditors selecting “Delay”
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may cause incorrect “Status” display.

(03) Fix [Add/Edit] > “Notification” > “Notice Mail Receiver(s)” : Unable to
receive notification emails due to format filtering errors.

)
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Mail Firewall—

Fix “Abnormal Sending Detection” : In some scenarios, emails are
incorrectly quarantined.
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K Anti-Virusx

Basic Setting—
Fix “Action of Unscannable Mail” : Unencrypted PDFs are deemed

J

unscannable.

Anti-Virus Engines—

(01) Fix “Kaspersky Setting” > “Check New Version of Engine” : Shows
“Update available” even on the latest version.

(02) Fix “Kaspersky Setting” : Shows “Update available” even when
Kaspersky is disable.

K Anti-Spam %

Basic Setting—
(01) Add “Al Module” (only available on some models, enable in “Package
Management” ).

(02) Fix In some scenarios, “Anti-Spam Setting” > “Mail after SMTP
Auth.” : Setting “Anti-Spam Again” is ineffective.

(03) Fix In some scenarios, spam filtering misjudges emails due to learning
database issue.

Notice Mail Setting—

Fix In some scenarios, when quarantined emails match “Audit & Filter
Rule Setting” > “Carbon Copy” , the status info in
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the notification email is incorrect.
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Spam Mail Learning—

Fix In some scenarios, enabling “Spam Mail Auto-learning” affects EDM
email accuracy.

System Black & White—

Fix Pressing Enter after entering text in the search bar results in an error.
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Spam Mail Protection—

J

Fix In some scenarios, “DMARC Check” settings are ineffective.

% User Management:¥%

Basic Setup—

(01) Adjust Some “WebMail Initial Setting” settings support New Webmail.
- “How To Display The Date Of The Message List”
- “Automatically Display Mail”

- “Font”

- “Compose Mode”

- “Preview Content Mode”

- “Compose Content Mode”

- “Skin”

- “Encode for Incoming Mail”

- “Encode for Outgoing Mail”

(02) Adjust Some “WebMail Advanced Setting” settings support New
Webmail.

- “Login page password-guessing attack defense”

(03) Fix “WebMail Advanced Setting” >” Message Rule limit” : In some
scenarios, settings fail to save.

(04) Fix “Google Calendar” > ” OAuth Redirect Uri” : Cannot save with '-'
character.
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Create Account—

Fix “Import Account from File/Create from Linux's System” : Import is

)
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allowed even when the password field is empty.

Account List—

Adjust [ Add/Edit] > “The first time login, change password” : New
Webmail supports this function.
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Central / Branch Setting—

(01) Fix In some scenarios, Sync fails.

J

(02) Fix Accounts with two-step verification do not correctly sync settings to
the branch server.

Password Security—

(01) Adjust “Password Comparison Rules” are shown only on New Webmail-
supported models.

(02) Adjust Default initial passwords are randomly generated according to
“Password Strength Limit” .

(03) Fix When “Password Strength Limit” is deselected, settings will be
reset.

Mail Migration—

(01) Fix “Transfer Mail by IMAP” : In some scenarios, transfers fail or
get interrupted.

(02) Fix “Transfer Mail by IMAP” : In some scenarios, Email retrieval is
incomplete due to errors of command judgement.

(03) Fix “Transfer Mail by IMAP” : Transfers fail when passwords
contain double quotes (") or backslashes (\).

(04) Fix “Domain transfer to localhost” > [ Select Account] : In some
scenarios, transfers fail when selecting too many accounts.

(05) Fix In some scenarios, errors in folder names result in proper email
retrieval.

2024/01/16 HERHSIANG FREEDY




"

% System Management

Administrator Accounts—

)
™

(01) Fix Accounts with “Two-Step Verification” do not receive verification
emails when HA standby server is logged in.

(02) Fix In some scenarios, two-step verification “Google Authenticator”
key does not update correctly.

(03) Fix In some scenarios, QR code does not display during two-step
verification “Google Authenticator” setup.

(04) Fix “Administrator Authority” > “Sub/Normal Administrator” :
Password is visible when editing or viewing accounts.
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(05) Fix In some scenarios, no admin accounts can execute

J

[ Administrator Accounts) permissions.

Logo Upload—
Fix “WebMail Logo Settings” : In some scenarios, uploaded images do
not display correctly.

System Backup—
(01) Adjust Add “Progress” link in “Status” field to view details.

(02) Fix In some scenarios, using multiple identical USB devices for
backup results in backup failure due to recognition issues.

(03) Fix In some scenarios, system/account restoration via FTP fails due
to server time settings.

(04) Fix [Edit] > “System Backup Maintain” > “Immediately Backup” :
Execution fails.

Restore user mailbox—

Fix In some scenarios, account restoration via FTP may fail due to
connection timeouts.

High Availability—

(01) Fix When syn is paused, the interface does not clearly indicate the status.
(02) Fix In some scenarios, switching servers causes email loss due to
improper sync.
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(03) Fix Standby server cannot send notification emails.
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System Command—

Fix “Power Schedule” : In some scenarios, scheduled reboots fail.

Message Notification—

(01) Add “Notification Items” > “The current hard dish is usb or iISCSI
device” setting.
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(02) Fix Notification emails are marked as spam due to subject encoding
issues.

J

SSL Certificate—

(01) Fix “SSL Certificate Setup” > “SSL Certificate Signing” : In some
scenarios, selecting “Manual input” fails to save.

(02) Fix Web service certificates are not updated correctly after changing the
certificate.

System Detection—

(01) Fix “Auto Database Detection / Repair Schedule” : Settings cannot be
saved due to password judgment errors.

(02) Fix In some scenarios, database detection shows incorrect results.

Remote Recording Server—
(01) Adjust “Log Item” > “Mail Log > Mail Log” : Add Spam Al.

- General: “Spam Al”
- CEF: ‘cs21Label=SpamAl”

(02) Adjust “Log Item” > “Mail Log > System Log > Pop3/Imap/WebMail
Log” .

- CEF: “cs2Label=UserName” Show full email info.
“cs3Label=AuthName” Show authentication account info.
- General: “user” Show full email info.
“auth_user” Show authentication account info.
(03) Fix “Log Format > CEF” Device Product info incorrect
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(04) Fix “Log Item” > “Mail Log > Mail Log” : In some scenarios, records
are not generated correctly.

)
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3%Mail Log3

Mail Log—
Fix In some scenarios, enabling central/branch architecture causes
incomplete email logs.
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SMTP Communication Log—

J

Fix In some scenarios, logs are not generated.

System Event Log—

Fix Executing [Backup] produces no data.

*%Flow Statistics:¥
Top N Mail Usage—

Fix Empty sender is included in statistics.

sk Dashboard

Home Page—
Adjust If accessing Dashboard without logging into the admin interface,
you will be redirected to the login page.

Others—

(01) Fix In some scenarios, data analysis causes excessive system load.

(02) Fix In some scenarios, country analysis is incorrect.

2024/01/16 HERHSIANG FREEDY




"

% New Webmail

Mail—

(01) Add Decrypt S/IMIME encrypted emails.

(02) Add Email list sorting feature

(03) Add [ Email Function Bar > Recall] Email recall feature
(04) Add [Mailbox: Star] includes all starred emails.

(05) Add [Advanced Search] includes additional items.

a@ael

- “Inbox: All inbox”

- “Date” includes date selection.

- “Size”

(06) Add [ Email Functions Menu] includes [Encode] settings.

(07) Add [Email > From] includes [Add/Edit Contact] settings.

(08) Add [Email > From] includes [Add to black/white list] settings.
)
)
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(09

(10) Adjust [ Email Function Bar > Download messages] supports multiple

Add Email attachments support Google/Microsoft doc online previews.

email downloads.
(11) Adjust [ Email > To] automatically collapses long recipient info.
(12) Adjust Order of [ Mailbox List] and [ Email Function Bar] .
(13
(14

(15) Fix Emal content isn’ t displayed in some scenarios.

Adjust Optimize Email List access efficiency.
Fix Unable to display Email List in some scenarios.

)
)
)
)
)
)

(16) Fix The [ Spam] button appears even when "Anti-Spam > Spam Mail
Learning" is disabled.

(17) Fix [ Email Function Bar > Clear Folder] does not fully remove data.
(18) Fix [ Mailbox: Sent] email content images missing.

(19) Fix [ Mailbox: Spam] attachments fail to download via [ Download as
zip]) .

(20) Fix Unable to use [Mailbox: Spam] > [Email Functions Menu] > [View
in separate window] / [ Download messages]

(21) Fix Unread email count is incorrect in some scenarios.

(22) Fix Reference mode operations and display is incorrect in some

scenarios.

(23) Fix Deleted emails change to read status.
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(24) Fix Deleting emails sometimes doesn’ t display or select the next email.

(25) Fix Pressing Enter after selecting an email sometimes doesn’ t open the
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email window.

(26) Fix External images in emails don't automatically load when the sender is
in contacts.

(27) Fix In some scenarios, trailing slashes in email hyperlinks are removed.

(28) Fix In some scenarios, email images or content are misaligned.
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)
(29) Fix Some event invitation emails don’ t display properly.
(30) Fix Signatures disappear in some reply emails.

)

(31) Fix In some scenarios, images deleted from emails turn into attachments

J

upon sending.

(32) Fix In some scenarios, [ CloudHDD] links fail to generate in the
compose window.

(33) Fix No prompt message when sending an email without a subject in the
compose window.

(34) Fix Content may disappear when resizing the compose window.

(35) Fix Sender name incorrect in notification emails for “Read receipts/2-
Step verification/Forgot Password” .

(36) Fix Incorrect timestamp in “New Device Login” natifications.

(37) Fix In some scenarios, [Search] results are incorrect.

(38) Fix Different results between [Search] and [Advanced Search] .

(39) Fix [Advanced Search]) > “Text” shows incorrect page numbers.
)

(40) Fix [Advanced Search] does not retain settings when opening the
configuration window after a query.

(41) Fix In some scenarios, [ Email Functions Menu > Print] shows blank
pages or garbled text.

Contacts—

(01) Adjust Add [Add Contact] interface; configurable in [ Compose] and
[ Calendar] .

(02) Adjust Contact list interface now includes custom fields.

(03) Fix Select group and [ Compose] , deleted contacts still appear in the
recipient list.

(04) Fix Select contacts and [ Compose] , recipient names are incorrect.
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(05) Fix In some scenarios, errors occur in [Delete] contacts.

(06) Fix [Search] results are incorrect.

ael

)

)
(07) Fix In some scenarios, contacts are added repeatedly.
(08) Fix Unable to remove contacts from “Shared Address Book™ directory.
)

(09) Fix Some contacts are not displayed in “Shared Address Book” .

Calendar—
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(01) Adjust When accepting private invitations, editing the events is possible.
(02) Adjust [Add/Edit calendar event] > [Invitation] shows response status.

(03) Fix “GOOGLE” > [[New Google account/Import from Google ]
execution failure.

(04) Fix "GOOGLE" > [ Synchronous] errors.

J

(05) Fix Language display errors in some scenarios.

(06) Fix Private event info not hidden in shared calendars.

)
)
)
(07) Fix Calendar display issues after creating cycle.
(08) Fix Layout problems after “Search” .

(09) Fix [ Advanced Search] may return incorrect results.
)

(10) Fix Calendar not synced after client-side email software replies to
invitations.

CloudHDD—

(01) Adjust Folder name used as file name in downloads.
(02) Fix Errors with [Upload]) over 1GB.

(03) Fix Errors with long [Upload] time.
)

(04) Fix Overwriting files with the same name incorrectly increases download
count.

(05) Fix Special characters (/:*?"<>|) in folder or file names may cause display
and operation issues.

Setting—
(01) Add [General] > “Language” setting.
(02) Add [General] > “SMTP mail backup way” setting (Enable the
permission in [User Management > Account List] ).
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(03) Add [General] > “Default encoding for incoming messages” setting.

(04) Add [General] > “Default encoding for outgoing messages” setting.
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(05) Add [General] > “Auto delete same Message-ID mail” setting.

(07) Add [Calendar] > “Week starts on” setting.
(08) Add [Download Area] function.

)
)
)
(06) Add [Calendar] > “Calendar events show mode” setting.
)
)
(09) Adjust [ General] > “How to display the date of the message list”

includes “Full” format.

(10) Adjust [ Mail Filter] > [ Add/Edit] includes “New message natification”
setting.

J @ 9

(11) Fix [ General] > [Account Name] cannot be modified.

(12) Fix [ General Settings] > "Notifications" > "New Mail Notification" not
working.

(13) Fix In some scenarios, [Folders] shows incorrect folder names.

(14) Fix [Mail Filter] > [Add Filter] > “Actions” folder menu shows
incorrect names.

(15) Fix [ Mail Filter] rules sometimes do not work.

(16) Fix [ Mail Filter] sometimes affects emails outside rules.
(17
(18

(19) Fix [Security] > “Bind LINE Notify” fails in some scenarios.

Fix [Personal Rule] Sometimes Black/White List are missing.
Fix [Accounts] > “Signatures” cannot be deleted.

)
)
)
)
)
)

(20) Fix [Security] > “2-Step verification” > “Email/Line” still sends
notifications for inactive options.

(21) Fix [Security] > “Change Password” : “Current password” fails
verification.

(22) Fix [ Themes] Uploading images disables right-click text copy.

Others—
(01) Add [Login Page] > [Account Application] feature.

(02) Adjust [Login Page] > [Forgot password]) now includes operation
prompt messages.

(03) Fix In some scenarios, 2-step verification does not work correctly.
(04) Fix Outdated password validation not prompted when switching accounts.
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(05) Fix Incorrect prompt message when new password matches old
password.

)
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(06) Fix Recipient limit does not match admin settings.
(07) Fix New email notifications are delayed.

(08) Fix Logging out from any window in multi-window use may cause display
errors on some pages.

9 I

sWebmail 3

Mail—

J

(01) Fix [Email Functions Menu > Print] shows excess or blank pages in
some scenarios.

(02) Fix Unable to download or preview attachments in some scenarios.
(03
(04

(05) Fix [From > Add to black/white list] sometimes does not work.

)
) Fix Email content not correctly displayed in some scenarios.
) Fix Spaces in email hyperlinks may cause link issues.

)

Contact—

Fix In some scenarios, contact selection window does not display fully.

Calendar—
(01) Adjust Optimize calendar data access for faster page loading.

(02) Adjust Private event invitations added to personal events now remain
editable.

(03) Adjust Adjust conflict event notifications; remove unnecessary
notifications.

(04) Adjust Outlook event invitations lack sender’ s name.
(05) Fix Incorrect timezone info in “Add/Modify” > “From/To” .

(06) Fix In some scenarios, notification emails display incorrectly.

EPaper—
(01) Add [[New Epaper] > [Upload File] shows “Spam Score” info.

(02) Fix [ New Epaper] > “Epaper Example” > [unsubscribe] link is
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invalid.
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Setting—
(01) Fix [Profile] > “Binding LINE Notify” fails in some scenarios.

(02) Fix [Personal Rule] Sometimes Black/White List are missing.

Others—
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(01) Adjust [Login Page] > [Forget Password] function will be disabled
after multiple requests.

(02) Fix [Login Page] > [ Create an account] shows verification failure in
some scenarios.

J

(03) Fix Browser icon incorrectly displays as a different icon in some
scenarios.

3%Mail APP3%
Mail—

Fix In some scenarios, encoding errors cause incorrect email content.
Calendar—

Fix Incorrect time display in some scenarios.

% Outlook Connector:«

Fix When Outlook calendar has a new event, it does not sync with

CalDAV.
% Others ¥

(01) Add Add top-right prompt on the homepage when booting from backup
drive (USB/iSCSI).

(02) Adjust Adjust default feature settings.

- Mail Server > Basic Setup | TLS encryption: Enabled
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- Mail Server > Basic Setup | Maximum Mail Size: 30 M Bytes

- Mail Record > Basic Setup | Mail Record Setting: Enabled; Keep Mail in
HDD: 180 Days.

- Mail Server > Advanced Setup | Quota Notice Setting: Enabled

- Mail Server > Service Management | POP3S, IMAPS: Enabled

- Mail Filter,Audit & Firewall > Mail Firewall | SMTP SASL: Enabled

- Anti-Virus > Basic Setting | Remove Attachment Contents: Enabled

- HERHSIANG Sandstorm > Basic Setup | Action of Match Mail: Add Spam
Score 5.

- Mail Log > Log Period Setting | System Event Log: 6 months
- Anti-Spam > Anti-Spam Engines | Link Filter: Add Spam Score 5

- Anti-Spam > Spam Mail Protection | IP Address PTR Check/ SPF Check/
DKIM Check: Enabled

- User Management > Password Security | Password Strength Limit:
Password length limit greater than 8, include

English uppercase, lowercase, numbers, and symbols
- System Management > Network Setup | DNS server: 8.8.8.8/1.1.1.1

- System Management > Software Upgrade | Auto Check and Download:
Download Method: Manually download

(03) Adjust Additional prompt message for incorrect password format.
(04) Fix [Home > History MRTG] > “Service Flow” IP info incorrect.

(05) Fix Incorrect language text on some feature interfaces.

API—

(01) Add Support access to [Home]) > “System Hardware Resources”
status.

(02) Fix No response after adding group accounts.

(03) Fix Some fields cannot be set when adding/editing group accounts.

Mail—

(01) Fix In some scenarios, SMTP Service does not work correctly after
booting.

(02) Fix Subject may not display correctly after renaming emails.
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(03) Fix Some emails have processing issues, leading to procedure freeze.

(04) Fix IMAP folder sync may fail if folder names contain slashes (/).
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Console—

Add HA service role and status info is now shown in status messages.

System—
(01) Adjust Enhance system security, adjusting data filtering and restriction for
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connection requests.

(02) Adjust Improve HTTP security in the user interface with additional header
security settings.
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(03) Adjust Optimize system memory management by dynamically adjusting
swap space based on capacity.

(04) Adjust Software license expiration will halt signature database updates
and queries.

(05) Fix Space filled up during system upgrade for some models.

(06) Fix In some scenarios, program errors create records and files that
consume space.

(07) Fix In some scenarios, incorrect file handling leaves residual data after
deleting or moving emails/logs.

(08) Fix CVE-2021-34555 OpenDMARC vulnerability.
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